VM のインポートとエクスポート

最終公開日 : Oct 07, 2026
XenServer® を使用すると、さまざまな形式の VM をインポートおよびエクスポートできます。
XenCenter の インポート ウィザードを使用すると、Open Virtualization Format (OVF および OVA)、ディスクイメージ形式 (VHD、VHDX/AVHDX、および VMDK)、および XenServer XVA 形式から VM をインポートできます。VMware や Microsoft が提供するような、他の仮想化プラットフォームで作成された VM もインポートできます。
注:
他の仮想化プラットフォームを使用して作成された VM をインポートする場合は、XenServer で起動するようにゲストオペレーティングシステムを構成または 修正 してください。XenCenter のオペレーティングシステム修正機能は、この基本的なレベルの相互運用性を提供することを目的としています。詳細については、「オペレーティングシステムの修正」を参照してください。
XenCenter® の エクスポート ウィザードを使用すると、Open Virtualization Format (OVF および OVA) および XenServer XVA 形式に VM をエクスポートできます。
xe CLI を使用して、XenServer XVA 形式の VM をインポートおよびエクスポートすることもできます。

要件

異なる形式の VM をインポートおよびエクスポートするには、特定の権限が必要です。インポート または エクスポート ウィザードは、続行する前に、宛先プールで必要な役割を持っていることを確認するためのチェックを実行します。必要な RBAC ロールの詳細については、「RBAC ロールと権限」を参照してください。

サポートされている形式

形式 インポートに対応していますか? エクスポートに対応していますか? 説明
オープン仮想化フォーマット (OVF および OVA) はい はい OVFは、1つ以上のVMで構成される仮想アプライアンスをパッケージ化および配布するためのオープン標準です。
ディスクイメージ形式 (VHD、VHDX/AVHDX、およびVMDK) はい いいえ Virtual Hard Disk (VHD)、Virtual Hard Disk Extended (VHDX)、Automatic Virtual Hard Disk (AVHDX)、およびVirtual Machine Disk (VMDK) 形式のディスクイメージファイルは、インポートウィザードを使用してインポートできます。
XenServer XVA形式 はい はい XVAは、ディスクリプタとディスクイメージを含む個々のVMを単一のファイルアーカイブとしてパッケージ化するための、Xenベースのハイパーバイザーに固有の形式です。そのファイル名拡張子は.xvaです。

使用する形式?

OVF/OVA形式を使用することを検討してください。
  • OVFをサポートする他の仮想化プラットフォームとXenServer vAppおよびVMを共有する
  • 複数のVMを保存する
次の場合、VHD、VHDX/AVHDX、またはVMDK形式の使用を検討してください。
  • 関連するOVFメタデータなしで仮想ディスクイメージが利用可能な場合
次を行うには、XVA形式の使用を検討してください。
  • CLIでスクリプトを実行してVMをインポートおよびエクスポートする

オープン仮想化形式 (OVFおよびOVA)

OVFは、Distributed Management Task Forceによって規定された、1つ以上のVMで構成される仮想アプライアンスをパッケージ化および配布するためのオープン標準です。OVFおよびOVA形式の詳細については、以下の情報を参照してください。
OVFパッケージは、仮想アプライアンスを構成するファイルのセットです。常に記述子ファイルと、パッケージの以下の属性を表すその他のファイルが含まれます。

属性

記述子 (.ovf): 記述子は常にパッケージの仮想ハードウェア要件を指定します。また、以下のようなその他の情報も指定できます。
  • 仮想ディスク、パッケージ自体、およびゲストオペレーティングシステムに関する説明
  • ライセンス契約
  • アプライアンス内のVMの起動と停止に関する指示
  • パッケージのインストールに関する指示
署名 (.cert): 署名は、X.509形式の公開鍵証明書によって使用され、パッケージの作成者を認証するためのデジタル署名です。
マニフェスト (.mf): マニフェストを使用すると、パッケージの内容の整合性を検証できます。これには、パッケージ内のすべてのファイルのSHA-1ダイジェストが含まれています。
仮想ディスク: OVFはディスクイメージ形式を指定しません。OVFパッケージには、仮想ディスクをエクスポートした仮想化製品によって定義された形式の仮想ディスクを構成するファイルが含まれています。XenServerはDynamic VHD形式のディスクイメージを含むOVFパッケージを生成し、VMware製品とVirtual BoxはStream-Optimized VMDK形式の仮想ディスクを含むOVFパッケージを生成します。
OVFパッケージは、圧縮、アーカイブ、EULAの添付、注釈など、メタデータ以外の機能もサポートしています。
注:
圧縮されているか、圧縮ファイルを含むOVFパッケージをインポートする場合、正しくインポートするためにXenServerホストに追加のディスク領域を解放する必要がある場合があります。
Open Virtual Appliance (OVA) パッケージは、OVFパッケージを構成するファイルを含む、Tape Archive (.tar) 形式の単一のアーカイブファイルです。

OVFまたはOVA形式を選択する

OVFパッケージには一連の非圧縮ファイルが含まれているため、ファイル内の個々のディスクイメージにアクセスしやすくなります。OVAパッケージには1つの大きなファイルが含まれており、このファイルを圧縮することはできますが、一連のファイルの柔軟性はありません。
OVA形式の使用は、Webダウンロード用のパッケージ作成など、1つのファイルであることが有益な特定のアプリケーションに役立ちます。OVAは、パッケージの処理を容易にするためのオプションとしてのみ検討してください。この形式を使用すると、エクスポートとインポートの両方のプロセスが長くなります。

ディスクイメージ形式 (VHD、VHDX/AVHDX、およびVMDK)

XenCenterを使用すると、Virtual Hard Disk (VHD)、Virtual Hard Disk Extended (VHDX)、Automatic Virtual Hard Disk (AVHDX)、およびVirtual Machine Disk (VMDK) 形式のディスクイメージをインポートできます。スタンドアロンのディスクイメージのエクスポートはサポートされていません。
VHDは、VMのディスクデータを保存するために使用される仮想ハードディスク形式です。VMDKは、VMwareに固有の仮想ディスク形式です。VHDXは、VHD形式の改良版です。VHDX/AVHDXの詳細については、VHDX/AVHDXを参照してください。
関連するOVFメタデータなしで仮想ディスクイメージが利用可能な場合に、ディスクイメージをインポートすることを選択できます。このオプションは、次の状況で発生する可能性があります。
  • ディスクイメージをインポートすることは可能ですが、関連するOVFメタデータが読み取り不能である
  • 仮想ディスクがOVFパッケージで定義されていない
  • OVFパッケージを作成できないプラットフォーム(例えば、古いプラットフォームやイメージ)から移行する場合
  • OVF情報を持たない古いVMwareアプライアンスをインポートしたい場合
  • OVF情報を持たないスタンドアロンVMをインポートしたい場合
利用可能な場合は、個別のディスクイメージではなく、OVFメタデータを含むアプライアンスパッケージをインポートすることをお勧めします。OVFデータは、インポートウィザードがディスクイメージからVMを再作成するために必要な情報を提供します。この情報には、VMに関連付けられたディスクイメージの数、プロセッサ、ストレージ、ネットワーク、およびメモリ要件が含まれます。この情報がないと、VMの再作成ははるかに複雑でエラーが発生しやすくなります。

VHDX/AVHDX

VHDXは、VHD形式の改良版であり、より大きな容量に加えて、パフォーマンス、耐障害性、およびデータ保護機能が向上しています。
AVHDXは、仮想ハードディスク用のVHDX標準の一部であるディスクイメージ形式です。VMのスナップショットまたはチェックポイント情報を保存するために使用されます。VMでスナップショットを作成するたびに、仮想ハードディスクの現在の状態を保持するためにAVHDXファイルが自動的に生成されます。このファイルは、VMのスナップショット情報を追跡するために使用できます。各AVHDXファイルは前のAVHDXファイルにリンクされており、ベースの仮想ハードディスクファイル以降に行われたすべての変更を含むチェーンを作成します。
XenCenterのインポートウィザードを使用して、VHDX/AVHDXファイルをプールまたは特定のホストにVMとしてインポートできます。XenCenterのインポートウィザードを使用してVHDX/AVHDXファイルをインポートする方法については、「ディスクイメージのインポート」を参照してください。
Citrixのお客様は、この機能を使用してVMをVMwareからXenServerに移行することもできます。Citrix Provisioningは、そのソフトウェアストリーミングテクノロジーの一部として、共有ディスクイメージ(vDisk)をVHDX/AVHDXファイルとして保存します。XenCenterのインポートウィザードを使用してVHDX/AVHDXファイルをインポートすることで、vDiskをVMwareからXenServerに簡単に移行できます。詳細については、「VMwareからの移行」を参照してください。

XVA形式

XVAはXenServer固有の仮想アプライアンス形式で、単一のVMを記述子とディスクイメージを含む単一のファイルセットとしてパッケージ化します。ファイル名拡張子は.xvaです。
記述子(ファイル名拡張子ova.xml)は、単一のVMの仮想ハードウェアを指定します。
ディスクイメージ形式はファイルのディレクトリです。ディレクトリ名は記述子内の参照名に対応し、ディスクイメージの1 MBブロックごとに2つのファイルを含みます。各ファイルのベース名は10進数のブロック番号です。最初のファイルは、ディスクイメージの1ブロックを生のバイナリ形式で含み、拡張子はありません。2番目のファイルは最初のファイルのチェックサムです。VMがCitrix Hypervisor 8.0以前からエクスポートされた場合、このファイルの拡張子は.checksumです。VMがCitrix Hypervisor 8.1以降からエクスポートされた場合、このファイルの拡張子は.xxhashです。
重要:
VMがXenServerホストからエクスポートされ、異なるCPUタイプの別のXenServerホストにインポートされた場合、正常に動作しない可能性があります。たとえば、Intel VT対応CPUを搭載したホストからエクスポートされたWindows VMは、AMD-VTM CPUを搭載したホストにインポートされた場合、実行されない可能性があります。

オペレーティングシステム修正

XenServer以外の仮想化プラットフォームで作成およびエクスポートされた仮想アプライアンスまたはディスクイメージをインポートする場合、XenServerホストで適切に起動する前にLinux VMを構成する必要がある場合があります。
XenCenterには、高度なハイパーバイザー相互運用性機能であるオペレーティングシステム修正が含まれており、XenServerにインポートするVMの基本的な相互運用性を確保することを目的としています。他の仮想化プラットフォームで作成されたOVF/OVAパッケージおよびディスクイメージからVMをインポートする際に、オペレーティングシステム修正を使用します。
オペレーティングシステム修正ISOは、XenCenterインストールのディレクトリC:\Program Files (x86)\XenServer\XenCenter\External Toolsにあります。
オペレーティングシステム修正プロセスは、あるハイパーバイザーから別のハイパーバイザーに移行する際に発生するオペレーティングシステムのデバイスおよびドライバーの問題に対処します。このプロセスは、インポートされたVMの起動デバイス関連の問題を修復しようとします。これにより、内部のオペレーティングシステムがXenServer環境で起動できなくなる可能性があります。この機能は、あるプラットフォームから別のプラットフォームへの変換を実行するようには設計されていません。
注:
この機能には、40 MBの空き容量と256 MBの仮想メモリを持つISOストレージリポジトリが必要です。
オペレーティングシステム修正は、インポートされたVMのDVDドライブに接続される自動起動ISOイメージとして提供されます。VMが最初に起動されると、必要な修復操作を実行し、その後VMをシャットダウンします。次に新しいVMが起動されると、起動デバイスがリセットされ、VMは正常に起動します。
インポートされたディスクイメージまたはOVF/OVAパッケージでオペレーティングシステム修正を使用するには、XenCenterのインポートウィザードのOS修正設定ページでこの機能を有効にします。XenServerが使用できるように、修正ISOがコピーされる場所を指定します。
Windows VMの場合、プールにConversion Manager 8.5.0以降がインストールされている場合、インポートプロセスはConversion Managerを呼び出して、インポートされたWindows VMを使用できるように準備します。この場合、オペレーティングシステム修正オプションは利用できません。

オペレーティングシステム修正はVMに何を行いますか?

オペレーティングシステム修正オプションは、仮想システムを起動できるようにするために可能な限り最小限の変更を行うように設計されています。ゲストオペレーティングシステムと元のホストのハイパーバイザーによっては、オペレーティングシステム修正の使用後にさらなるアクションが必要になる場合があります。これらのアクションには、構成変更やドライバーのインストールが含まれる場合があります。
修正プロセス中に、ISOがISO SRにコピーされます。ISOはVMに接続されます。起動順序は仮想DVDドライブから起動するように設定され、VMはISOから起動します。その後、ISO内の環境はVMの各ディスクをチェックし、それがLinuxシステムかWindowsシステムかを判断します。
Linuxシステムが検出された場合、GRUB構成ファイルの場所が特定されます。SCSIディスク起動デバイスへのポインターは、IDEディスクを指すように変更されます。たとえば、GRUBに最初のSCSIコントローラー上の最初のディスクを表す/dev/sda1のエントリが含まれている場合、このエントリは最初のIDEコントローラー上の最初のディスクを表す/dev/hda1に変更されます。
VM内で特定の仮想化ツールセットが検出された場合、パフォーマンスの問題や不要なイベントメッセージを防ぐために無効にされます。
注記:
Operating System Fixup オプションは、RHEL ファミリーのディストリビューションではサポートされていません。起動すると、インポートされた RHEL VM は緊急モードに入ります。この問題を回避するには、レスキューモードで再起動し、dracut --regenerate-all --force を実行してから、VM を再度再起動します。

VM のインポート

VM をインポートすると、新しい VM をプロビジョニングするために必要な多くの手順を使用して、実質的に VM を作成することになります。これらの手順には、ホストの指定、ストレージとネットワークの構成が含まれます。
XenCenter の インポート ウィザードを使用して、OVF/OVA、ディスクイメージ、XVA、および XVA バージョン 1 ファイルをインポートできます。xe CLI を介して XVA ファイルをインポートすることもできます。
注記:
より新しいシステムからエクスポートされた VM を、より古いシステムにインポートできることは保証されません。たとえば、Early Access 更新チャネルで最新レベルのホストから VM をエクスポートした場合、Normal 更新チャネルで最新レベルのホストにこの VM をすぐにインポートできない場合があります。そのホストに VM をインポートする前に、Normal チャネルのホストは、VM がエクスポートされた時点の Early Access チャネルと同じレベルの更新に達している必要があります。
この動作は、後の更新で追加される可能性のある追加のメタデータが原因であり、以前のバージョンでは理解できません。

OVF/OVA から VM をインポートする

XenCenter の インポート ウィザードを使用すると、OVF/OVA ファイルとして保存された VM をインポートできます。インポート ウィザードは、XenCenter で VM を作成するための通常の手順(ホストの指定、新しい VM のストレージとネットワークの構成)を案内します。OVF および OVA ファイルをインポートする場合、次のような追加の手順が必要になることがあります。
  • 他の仮想化プラットフォームを使用して作成された Linux VM をインポートする場合は、Operating System Fixup 機能を実行して、VM の基本的な相互運用性を確保します。詳細については、「Operating system fixup」を参照してください。

前提条件

  • ターゲットホストに、インポートされる仮想マシンをサポートするのに十分な RAM があることを確認してください。利用可能な RAM が不足していると、インポートは失敗します。
XenCenter を使用してインポートされた OVF パッケージは、vApp として表示されます。インポートが完了すると、新しい VM は XenCenter の リソース ペインに表示され、新しい vApp は vApp の管理 ダイアログボックスに表示されます。
XenCenter を使用して OVF/OVA から VM をインポートするには:
  1. 「リソース」ペインで、パッケージをインポートするホストまたはプールを選択します。
  2. 「ファイル」メニューで「インポート」を選択します。「インポート」ウィザードが開きます。
  3. ウィザードの最初のページで、インポートするOVA/OVFファイルを見つけて、「次へ」をクリックして続行します。
    • 圧縮されたOVAファイル ( *.ova.gz ) を選択した場合、「次へ」をクリックすると、ファイルはOVAファイルに解凍され、古い *.ova.gz ファイルは削除されます。
    • 「ファイル名」ボックスにURLの場所(HTTP、HTTPS、ファイル、FTP)を入力し、「次へ」をクリックすると、「パッケージのダウンロード」ダイアログが開きます。このダイアログで、OVA/OVFをコピーするXenCenterホスト上のフォルダーを指定します。
  4. (オプション) EULAを確認して同意します。 OVF/OVAにEULAが含まれている場合、「EULA」ページにEULAテキストが表示されます。EULAに同意する場合は、「同意する」を選択して続行します。
  5. テンプレートを指定します。 「テンプレート」ページで、OVA/OVFファイルからインポートするVMまたはVMsに使用するテンプレートを選択します。XenServerに付属のデフォルトテンプレートのみがサポートされています。カスタムテンプレートは使用しないでください。
    このパネルでは、Windows Updateを使用してI/Oドライバーを更新するかどうかも選択できます。
    「次へ」をクリックして続行します。
  6. (オプション) XenServer VM Toolsをインストールします (Windows VMのみ) プールでConversion Manager仮想アプライアンスバージョン8.5.0以降が実行されている場合、インポートの一部としてWindows用XenServer VM Toolsをインストールすることを選択できます。このツールインストールプロセスは、インポートされたVMが最初に起動した後に実行されます。このオプションを利用するには、VMディスクが共有ストレージ上にあるか、Conversion Managerと同じホスト上にある必要があります。
    1. 「XenServer® VM Toolsをインストール」を選択します。
    2. インストールするツールのバージョンを選択します。以下のオプションのいずれか、または複数が利用可能です。
      • Conversion Managerにアップロードされたツールのバージョン
      • インターネットからダウンロードされた最新バージョン
      • XenCenter®からアクセス可能な場所にあるツールインストールファイル
    3. 「次へ」をクリックして続行します。
  7. (オプション) VMの場所を指定します。「場所」ページで、インポートするVMをサーバーのローカルストレージに配置する場合は、サーバーを選択します。
    「次へ」をクリックして続行します。
  8. 新しいVMのストレージを構成します。
    「ストレージ」ページで、インポートされた仮想ディスクが配置されるストレージリポジトリ (SR) を選択します。インポートの一部としてXenServer VM Toolsをインストールすることを選択した場合は、VMディスクが共有ストレージ上にあるか、Conversion Managerと同じホスト上にあることを確認してください。
    「次へ」をクリックして続行します。
  9. 新しいVMのネットワークを構成します。
    「ネットワーク」ページで、新しいVMの仮想ネットワークインターフェイスの宛先プール/スタンドアロンサーバー内のターゲットネットワークを選択します。
    「次へ」をクリックして続行します。
  10. (オプション) **セキュリティ設定を指定します。**選択したOVF/OVAパッケージが証明書やマニフェストなどのセキュリティ機能で構成されている場合は、「セキュリティ」ページで必要な情報を指定します。「次へ」を選択して続行します。OVFパッケージで構成されているセキュリティ機能に応じて、このページには異なるオプションが表示されます。
    • パッケージが署名されている場合、「デジタル署名を検証」チェックボックスが表示されます。署名を検証する場合は、このチェックボックスを選択します。「証明書の表示」をクリックして、パッケージの署名に使用された証明書を表示します。証明書が信頼されていないと表示される場合、ルート証明書または発行元の認証局のいずれかがローカルコンピューターで信頼されていない可能性があります。
    • パッケージにマニフェストが含まれている場合、「マニフェストの内容を検証」チェックボックスが表示されます。ウィザードにパッケージ内のファイルリストを検証させるには、このチェックボックスを選択します。
    パッケージがデジタル署名されている場合、関連するマニフェストは自動的に検証されるため、「マニフェストの内容を検証」チェックボックスは「セキュリティ」ページには表示されません。
    「次へ」をクリックして続行します。
  11. (オプション) オペレーティングシステム修正を有効にします。 (Linux VMのみ) すべてのVMがWindows VMの場合、このパネルは表示されません。
    インポートするLinux VMがXenServer以外のハイパーバイザーで構築されている場合、「Use Operating System Fixup」を選択します。XenServerが使用できるように、Fixup ISOをコピーできるISO SRを選択します。詳細については、「VMのインポートとエクスポートについて」を参照してください。
    「Next」をクリックして続行します。
  12. 「Finish」ページで、すべてのインポート設定を確認します。「Finish」をクリックしてインポートプロセスを開始し、ウィザードを閉じます。
インポートが完了すると、新しくインポートされたVMが「Resources」ペインに表示され、新しいvAppが「vAppの管理」ダイアログに表示されます。
注:
プールでConversion Manager仮想アプライアンスバージョン8.5.0以降が実行されている場合、インポートされたWindows VMが最初に起動した後、VMware Toolsが存在すれば自動的に削除されます。

ディスクイメージのインポート

XenCenterのインポートウィザードを使用すると、ディスクイメージをプールまたは特定のホストにVMとしてインポートできます。インポートウィザードは、XenCenterでVMを作成するための通常の手順(ホストの指定、新しいVMのストレージとネットワークの構成)を案内します。

前提条件

  • XenServerが使用している管理ネットワークでDHCPが実行されていることを確認してください。
  • インポートウィザードを実行するサーバーには、ローカルストレージが必要です。

XenCenterを使用してディスクイメージからVMをインポートするには

  1. 「Resources」ペインで、パッケージをインポートするホストまたはプールを選択します。
  2. 「File」メニューで「Import」を選択します。インポートウィザードが開きます。
  3. ウィザードの最初のページで、インポートするディスクイメージファイルを見つけ、「Next」をクリックして続行します。
    「ファイル名」ボックスにURLロケーション(HTTP、HTTPS、ファイル、FTP)を入力し、「次へ」をクリックすると、「パッケージのダウンロード」ダイアログが開きます。このダイアログで、ディスクイメージをコピーするXenCenterホスト上のフォルダーを指定します。
  4. テンプレートを指定します。 ディスクイメージをインポートするVMに使用するテンプレートを選択します。XenServerに付属のデフォルトテンプレートのみがサポートされています。カスタムテンプレートは使用しないでください。
    このパネルでは、BIOS文字列をVMにコピーするかどうか、およびWindows Updateを使用してI/Oドライバーを更新するかどうかも選択できます。
    「次へ」をクリックして続行します。
  5. (オプション)XenServer VM Toolsをインストールします(Windows VMのみ)プールでConversion Manager仮想アプライアンスバージョン8.5.0以降が実行されている場合、インポートの一部としてWindows用XenServer VM Toolsをインストールすることを選択できます。このツールインストールプロセスは、インポートされたVMが最初に起動した後に実行されます。このオプションを利用するには、ディスクイメージが共有ストレージ上にあるか、Conversion Managerと同じホスト上にある必要があります。
    1. 「XenServer VM Toolsをインストール」を選択します。
    2. インストールするツールのバージョンを選択します。以下のオプションの1つ以上が利用可能です。
      • Conversion Managerにアップロードされたツールのバージョン
      • インターネットからダウンロードされた最新バージョン
      • XenCenterからアクセス可能な場所にあるツールインストールファイル
    3. 「次へ」をクリックして続行します。
  6. VM名を指定します。
    「名前」ページで、インポートされたディスクイメージから作成する新しいVMの名前を入力します。この値は、新しいVMが作成された後で調整できます。XenCenter内ではVM名の一意性はチェックされないため、意味のある覚えやすい名前を付けると、異なるVMを管理しやすくなります。詳細については、「VM名と説明」を参照してください。
    「次へ」をクリックして続行します。
  7. CPUとメモリリソースを割り当てます。
    「CPUとメモリ」ページで、CPUと初期メモリリソースを割り当てます。これらの値は、新しいVMが作成された後で調整できます。詳細については、「VMのCPUとメモリの割り当て」(/ja-jp/xencenter/current-release/vms-new-cpu-memory.html)を参照してください。
    「次へ」をクリックして続行します。
  8. (オプション) VMの場所を指定します。 「場所」ページで、インポートするVMをサーバーのローカルストレージに配置する場合は、サーバーを選択します。
    「次へ」をクリックして続行します。
  9. 新しいVMのストレージを構成します。
    「ストレージ」ページで、インポートされた仮想ディスクが配置されるストレージリポジトリ (SR) を選択します。インポートの一部としてXenServer VM Toolsをインストールすることを選択した場合は、ディスクイメージが共有ストレージ上にあるか、Conversion Managerと同じホスト上にあることを確認してください。
    「次へ」をクリックして続行します。
  10. 新しいVMのネットワークを構成します。
    「ネットワーク」ページで、新しいVMの仮想ネットワークインターフェースの宛先プール/スタンドアロンサーバー内のターゲットネットワークを選択します。
    「次へ」をクリックして続行します。
  11. 起動オプションを指定します。
    「起動オプション」ページで、新しいVMの起動モードを指定します。ゲストオペレーティングシステムでサポートされているオプションのみを選択できます。
    • BIOSブート: このオプションを選択すると、VMがレガシーBIOSモードで起動します。レガシーBIOSブートは、Windows 11 VMではサポートされていません。
    • UEFIブート: このオプションを選択すると、VMがUEFIモードで起動します。XenServerは、特定のゲストオペレーティングシステムでのみこの起動モードをサポートしています。UEFIブートがサポートされているゲストオペレーティングシステムの詳細については、「ゲストUEFIブートとセキュアブート」(/ja-jp/xenserver/9/vms.html#guest-uefi-boot-and-secure-boot)を参照してください。
    • UEFIセキュアブート: このオプションを選択すると、VMがUEFIセキュアブートモードで起動します。セキュアブートは、署名されていない、署名が正しくない、または変更されたバイナリが起動中に実行されるのを防ぎます。XenServerは、特定のゲストオペレーティングシステムでのみこの起動モードをサポートしています。UEFIセキュアブートがサポートされているゲストオペレーティングシステムの詳細については、「ゲストUEFIブートとセキュアブート」(/ja-jp/xenserver/9/vms.html#guest-uefi-boot-and-secure-boot)を参照してください。
    (VHDX/AVHDXのみ) VHDX/AVHDXファイルからVMをインポートする場合、インポートウィザードは、インポートするVHDX/AVHDXファイルから起動モードを自動的に検出します。設定を確認し、VMに元々構成されていた起動モードが選択されていることを確認してください。
    次へをクリックして続行します。
  12. (オプション) オペレーティングシステム修正を有効にする。Windowsテンプレートを選択した場合、このパネルは表示されません。
    インポートするディスクイメージがXenServer以外のハイパーバイザーで構築されている場合は、オペレーティングシステム修正を使用を選択します。XenServerが使用できるように、修正ISOをコピーできるISO SRを選択します。詳細については、VMのインポートとエクスポートについてを参照してください。
    重要:
    VMware vSphere上で稼働するCitrix Provisioning (PVS) からVHDX/AVHDXファイルをインポートする際には、「オペレーティングシステム修正を使用しない」を選択してください。PVSからインポートしたVHDX/AVHDXファイルにオペレーティングシステム修正を適用すると、起動に失敗する恐れがあります。
    次へをクリックして続行します。
  13. 完了ページで、すべてのインポート設定を確認します。完了をクリックしてインポートプロセスを開始し、ウィザードを閉じます。
    インポートの進行状況は、XenCenterウィンドウの下部にあるステータスバーと、通知の下にあるイベントビューにも表示されます。
インポートプロセスには時間がかかる場合があります。かかる時間は、インポートされる仮想ディスクのサイズ、利用可能なネットワーク帯域幅、およびXenCenterホストのディスクインターフェイス速度によって異なります。インポートが完了すると、新しくインポートされたVMがリソースペインに表示されます。
注:
プールでConversion Manager仮想アプライアンスバージョン8.5.0以降が実行されている場合、インポートされたVMが最初に起動した後、VMwareツールが存在すれば、自動的に削除されます。

次のステップ

Windows用XenServer VM Toolsが完全にインストールされていることを確認してください。
  • インポートプロセスの一部としてWindows用XenServer VM Toolsをインストールすることを選択した場合、インポート後にVMを再起動して、ツールのインストールを完了してください。
  • インポートプロセスの一部としてWindows用XenServer VM Toolsをインストールしないことを選択した場合、VMが完全にサポートされるように、後で手動でインストールしてください。詳細については、「XenServer VM Toolsのインストール」(/ja-jp/xencenter/current-release/vms-installtools.html)を参照してください。

XVAからのVMのインポート

以前にエクスポートされ、XVA形式でローカルに保存されたVM、テンプレート、およびスナップショットをインポートできます (.xva)。これを行うには、VMを作成するための通常の手順に従います。ホストを指名し、新しいVMのストレージとネットワークを構成します。
警告:
異なるCPUタイプを持つ別のホストからエクスポートされたインポート済みVMを実行できない場合があります。たとえば、Intel VT対応CPUを搭載したホストからエクスポートされたWindows VMは、AMD-VTM CPUを搭載したホストにインポートされた場合、実行できない可能性があります。
XenCenterを使用してXVAからVMをインポートするには:
  1. 次のいずれかの方法でインポートウィザードを開きます。
    • リソースペインで右クリックし、ショートカットメニューからインポートを選択します。
    • ファイルメニューでインポートを選択します。
  2. ウィザードの最初のページで、インポートするファイル (.xva または ova.xml) を見つけて、次へをクリックして続行します。
    ファイル名ボックスにURLの場所 (http、https、file、または ftp) を入力した場合。次へをクリックすると、ダウンロードパッケージダイアログボックスが開き、ファイルをコピーするXenCenterホスト上のフォルダーを指定する必要があります。
  3. インポートするVMの起動元となるプールまたはホストを選択し、次へを選択して続行します。
  4. インポートする仮想ディスクを配置するストレージリポジトリを選択し、次へをクリックして続行します。
  5. インポートするVMのネットワークを構成します。インポートするVM内の仮想ネットワークインターフェイスを、宛先プール内のネットワークにマッピングします。受信VMのリストに表示されるネットワークとMACアドレスは、エクスポートファイル内の元の(エクスポートされた)VMの定義の一部として保存されます。受信仮想ネットワークインターフェイスをターゲットネットワークにマッピングするには、ターゲットネットワーク列のリストからネットワークを選択します。次へをクリックして続行します。
  6. インポート設定を確認し、完了をクリックしてインポートプロセスを開始し、ウィザードを閉じます。
    注記:
    VMのインポートには、VMのサイズ、ネットワーク接続の速度と帯域幅に応じて、時間がかかる場合があります。
インポートの進行状況は、XenCenterウィンドウの下部にあるステータスバーと、通知 > イベントビューに表示されます。新しくインポートされたVMが利用可能になると、リソースペインに表示されます。
xe CLIを使用してXVAからVMをインポートするには:
ターゲットのXenServerホスト上のデフォルトのSRにVMをインポートするには、以下を入力します。
xe vm-import -h hostname -u root -pw password \
    filename=pathname_of_export_file
ターゲットのXenServerホスト上の別のSRにVMをインポートするには、オプションのsr-uuidパラメーターを追加します。
xe vm-import -h hostname -u root -pw password \
    filename=pathname_of_export_file sr-uuid=uuid_of_target_sr
元のVMのMACアドレスを保持したい場合は、オプションのpreserveパラメーターを追加し、trueに設定します。
xe vm-import -h hostname -u root -pw password \
    filename=pathname_of_export_file preserve=true
注記:
VMのインポートには、VMのサイズ、ネットワーク接続の速度と帯域幅に応じて、時間がかかる場合があります。
VMがインポートされると、コマンドプロンプトは新しくインポートされたVMのUUIDを返します。

VMのエクスポート

XenCenterエクスポートウィザードを使用してOVF/OVAファイルとXVAファイルをエクスポートできます。xe CLIを使用してXVAファイルをエクスポートすることもできます。
注記
VMがエクスポートされると、VMグループ設定は保持されません。

VMをOVF/OVAとしてエクスポート

XenCenterのエクスポートウィザードを使用して、1つ以上のVMをOVF/OVAパッケージとしてエクスポートできます。VMをOVF/OVAパッケージとしてエクスポートすると、各VMの仮想ハードディスクとともに構成データがエクスポートされます。
XenCenterを使用してVMをOVF/OVAとしてエクスポートするには:
  1. エクスポートするVMをシャットダウンまたは一時停止します。
  2. エクスポートウィザードを開きます。リソースペインで、エクスポートするVMを含むプールまたはホストを右クリックし、エクスポートを選択します。
  3. ウィザードの最初のページで:
    • エクスポートファイルの名前を入力します
    • ファイルを保存するフォルダーを指定します
    • フォーマットリストからOVF/OVAパッケージ (*.ovf, *.ova) を選択します
    • 次へをクリックして続行します
  4. 利用可能なVMのリストから、OVF/OVAパッケージに含めるVMを選択し、次へをクリックして続行します。
  5. 必要に応じて、以前に準備したエンドユーザーライセンス契約 (EULA) ドキュメント (.rtf, .txt) をパッケージに追加できます。
    EULAを追加するには、追加をクリックし、追加するファイルを参照します。ファイルを追加したら、EULAファイルリストから選択し、表示をクリックしてドキュメントを表示できます。
    EULAは、アプライアンスおよびアプライアンスで提供されるアプリケーションを使用するための法的条件を提供できます。
    1つ以上のEULAを含める機能により、アプライアンス上のソフトウェアを法的に保護できます。たとえば、アプライアンスのVMに独自のオペレーティングシステムが含まれている場合、そのオペレーティングシステムのEULAテキストを含めることができます。テキストが表示され、アプライアンスをインポートする人はそれを受け入れる必要があります。
    注:
    サポートされていない形式(XMLファイルやバイナリファイルなど)のEULAファイルを追加しようとすると、EULAインポート機能が失敗する可能性があります。
    続行するには、次へを選択します。
  6. 詳細オプションページで、マニフェスト、署名、および出力ファイルのオプションを指定するか、次へをクリックして続行します。
    1. パッケージのマニフェストを作成するには、マニフェストを作成チェックボックスを選択します。
      マニフェストは、パッケージ内の他のファイルのインベントリまたはリストを提供します。マニフェストは、パッケージが作成されたときに元々含まれていたファイルが、パッケージが到着したときに存在するファイルと同じであることを確認するために使用されます。ファイルがインポートされると、チェックサムを使用して、パッケージが作成されてからファイルが変更されていないことを確認します。
    2. パッケージにデジタル署名を追加するには
      1. OVFパッケージに署名を選択します。
        デジタル署名 (.cert) には、マニフェストファイルの署名と、その署名を作成するために使用された証明書が含まれています。署名されたパッケージがインポートされると、ユーザーは証明書の公開鍵を使用してデジタル署名を検証することで、パッケージ作成者の身元を確認できます。
      2. 証明書を見つけるには、参照します。
        信頼された機関からすでに作成し、.pfx ファイルとしてエクスポートしたX.509証明書を使用します。SHA-256ダイジェストを持つ証明書の場合は、CSPとして「Microsoft Enhanced RSA and AES Cryptographic Provider」を使用してエクスポートします。
      3. 秘密鍵のパスワードに、エクスポート(PFX)パスワードを入力するか、エクスポートパスワードが提供されていない場合は、証明書に関連付けられた秘密鍵を入力します。
    3. 選択したVMをOVA形式の単一の(tar)ファイルとして出力するには、**OVAパッケージを作成(単一のOVAエクスポートファイル)**チェックボックスを選択します。異なるファイル形式の詳細については、オープン仮想化形式を参照してください。
    4. パッケージに含まれる仮想ハードディスクイメージ(.VHDファイル)を圧縮するには、OVFファイルを圧縮チェックボックスを選択します。
      OVFパッケージを作成すると、仮想ハードディスクイメージは、デフォルトで、エクスポートされたVMと同じ量のスペースが割り当てられます。たとえば、26 GBのスペースが割り当てられたVMには、26 GBのスペースを消費するハードディスクイメージがあります。ハードディスクイメージは、VMが実際にそれを必要とするかどうかにかかわらず、このスペースを使用します。
      注:
      VHDファイルを圧縮すると、エクスポート処理の完了に時間がかかります。圧縮されたVHDファイルを含むパッケージをインポートする場合も、インポートウィザードがインポート時にすべてのVHDイメージを抽出する必要があるため、時間がかかります。
    OVAパッケージの作成(単一のOVAエクスポートファイル)とOVFファイルの圧縮の両方がチェックされている場合、結果は拡張子.ova.gzを持つ圧縮されたOVAファイルになります。
  7. エクスポート設定を確認します。
    ウィザードにエクスポートされたパッケージを検証させるには、完了時にエクスポートを検証チェックボックスを選択します。完了をクリックしてエクスポート処理を開始し、ウィザードを閉じます。
    注:
    VMのエクスポートには、VMのサイズ、ネットワーク接続の速度と帯域幅に応じて時間がかかる場合があります。
エクスポートの進行状況は、XenCenterウィンドウの下部にあるステータスバーと、通知 > イベントビューに表示されます。進行中のエクスポートをキャンセルするには、通知 > イベントビューをクリックし、イベントのリストからエクスポートを見つけて、キャンセルボタンをクリックします。

VMをXVAとしてエクスポートする

既存のVMは、XenCenterのエクスポートウィザードまたはxe CLIを使用してXVAファイルとしてエクスポートできます。エクスポートファイルのライブラリを維持できるXenServerホスト以外のマシンにVMをエクスポートすることをお勧めします。たとえば、XenCenterを実行しているマシンにVMをエクスポートできます。
警告:
CPUタイプが異なる別のホストからエクスポートされたインポート済みVMを常に実行できるとは限りません。たとえば、Intel VT Enabled CPUを搭載したホストからエクスポートされたWindows VMは、AMD-VTM CPUを搭載したホストにインポートされた場合、実行できない可能性があります。
XenCenterを使用してVMをXVAファイルとしてエクスポートするには:
  1. エクスポートするVMをシャットダウンまたは一時停止します。
  2. エクスポートウィザードを開きます。リソースペインから、エクスポートするVMを右クリックし、エクスポートを選択します。
  3. ウィザードの最初のページで:
    • エクスポートファイルの名前を入力します。
    • ファイルを保存するフォルダーを指定します。
    • フォーマットリストから**XVAファイル (*.xva)**を選択します。
    • 続行するには次へをクリックします。
  4. 利用可能なVMのリストからエクスポートしたいVMを選択し、次へをクリックして続行します。
  5. エクスポート設定を確認します。
    ウィザードにエクスポートされたパッケージを検証させるには、完了時にエクスポートを検証チェックボックスを選択します。完了をクリックしてエクスポートプロセスを開始し、ウィザードを閉じます。
    注:
    VMのエクスポートには、VMのサイズ、ネットワーク接続の速度と帯域幅に応じて時間がかかる場合があります。
エクスポートの進行状況は、XenCenterウィンドウの下部にあるステータスバーと、通知 > イベントビューに表示されます。進行中のエクスポートをキャンセルするには、通知 > イベントビューをクリックし、イベントのリストからエクスポートを見つけて、キャンセルボタンをクリックします。
xe CLIを使用してVMをXVAファイルとしてエクスポートするには:
  1. エクスポートしたいVMをシャットダウンします。
  2. 以下を実行してVMをエクスポートします。
    xe vm-export -h hostname -u root -pw password vm=vm_name \
        filename=pathname_of_file
    注:
    エクスポートファイル名を指定する際は、.xva拡張子を含めるようにしてください。エクスポートされたVMにこの拡張子がない場合、インポートしようとしたときにXenCenterがそのファイルを有効なXVAファイルとして認識できない可能性があります。